EF 4.2

Nov 11, 2011 at 3:54 AM

Tried to install the scaffolding package via NuGet after installing EntityFramework 4.2 package. 

However, it doesn't seem to be compatible and fails on install.

Is this just a NuGet issue or does development need to be done on scaffolding to work with 4.2?

Coordinator
Nov 11, 2011 at 5:34 AM

RIA Services itself does not support EntityFramework 4.2. Once RiaServices.EntityFramework itself is upgraded to support EntityFramework 4.2 this problem will go away.

This problem was caused by the Entity Framework team renumbering their versions. 4.2 was originally projected to be a version that was not compatible with RIA Services so the RIA Services team put a restriction on the NuGet versioning that the EntityFramework version had to be less then 4.2.